Mein MATLAB Forum - goMatlab.de

Mein MATLAB Forum

 
Gast > Registrieren       Autologin?   
Bücher:

Fachkräfte:
Informatiker (m/w) für den Bereich Toolkette Embedded Software
Weiterentwicklung einer MATLAB- / Simulink-Toolkette
cbb-Software GmbH - Stuttgart

Softwarearchitekt (m/w)
Entwicklung mit Matlab / Simulink und MISRA-C
SEG Automotive Germany GmbH - Stuttgart-Weilimdorf

SW-Entwickler/in SiL Motorsteuerung
Erstellung und Erweiterung von kundenspezifischen Simulationsmodellen in MATLAB/Simulink
Robert Bosch GmbH - Schwieberdingen

Softwareentwickler (m/w) automatische Codegenerierung
Umsetzung, Neuprogrammierung und Weiterentwicklung in Simulink, TargetLink und C
EFS - Ingolstadt, Wolfsburg

Entwicklungsingenieur (m/w) Umfelderfassung und Sensorfusion
Definition von Anforderungen und Analyse hinsichtlich einer Umfelderfassung mit verschiedenen Sensorsystemen
Bertrandt Ingenieurbüro GmbH - Frankfurt am Main

weitere Angebote

Partner:


Vermarktungspartner


Forum
      Option
[Erweitert]
  • Diese Seite per Mail weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

PDE - fehlerhafte unvollständige Geometrieerstellung

 

nadine19
Forum-Newbie

Forum-Newbie


Beiträge: 1
Anmeldedatum: 15.08.16
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 15.08.2016, 18:31     Titel: PDE - fehlerhafte unvollständige Geometrieerstellung
  Antworten mit Zitat      
Hallo an Alle,

ich arbeite mich momentan in die PDE Toolbox ein und habe folgendes Problem:

Ich habe ein Polygon (x- und y-Werte) mit 1249 Punkten gegeben.
Über die unten gezeigten Funktionen erstelle ich mir mein Polygon und kontrolliere es.

Code:
%
model = createpde();

gd = [2
    1248
    x'
    y'];

gstat = csgchk(gd);

[dl,bt] = decsg(gd);

 figure
 pdegplot(dl,'EdgeLabels','on');
 xlim([-15,15])
 axis equal
 


Aus irgendeinem Grund wird die Geometrie fehlerhaft aufgenommen.
Es entsteht ein Punkt der eigentlich in meiner Geometrie liegt, aber als Teil des Randes der Geometrie zählt. In meinen vorgegebenen x- und y-Werten ist dieser Punkt nicht enthalten.
Zur Veranschaulichung hänge ich den Plot als PDF an.

Ich weiß ehrlich nicht was ich tun kann um das Problem zu beheben. So kann ich auf keinen Fall weiter arbeiten. Crying or Very sad


Ich würde mich riesig über einen Tipp freuen.

poly.pdf
 Beschreibung:

Download
 Dateiname:  poly.pdf
 Dateigröße:  401.45 KB
 Heruntergeladen:  95 mal
Private Nachricht senden Benutzer-Profile anzeigen


Neues Thema eröffnen Neue Antwort erstellen



Einstellungen und Berechtigungen
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum posten
Du kannst Dateien in diesem Forum herunterladen
.


goMatlab ist ein Teil des goForen-Labels
goForen.de goMATLAB.de goLaTeX.de goPCB.de


 Impressum  | Nutzungsbedingungen  | Datenschutz  | Werbung/Mediadaten | Studentenversion | FAQ | goMatlab RSS Button RSS


Copyright © 2007 - 2018 goMatlab.de | Dies ist keine offizielle Website der Firma The Mathworks
Partner: LabVIEWforum.de

MATLAB, Simulink, Stateflow, Handle Graphics, Real-Time Workshop, SimBiology, SimHydraulics, SimEvents, and xPC TargetBox are registered trademarks and The MathWorks, the L-shaped membrane logo, and Embedded MATLAB are trademarks of The MathWorks, Inc.