Mein MATLAB Forum - goMatlab.de

Mein MATLAB Forum

 
Gast > Registrieren       Autologin?   
Bücher:

Fachkräfte:
SW-Entwickler/in SiL Motorsteuerung
Erstellung und Erweiterung von kundenspezifischen Simulationsmodellen in MATLAB/Simulink
Robert Bosch GmbH - Schwieberdingen

Softwarearchitekt (m/w)
Entwicklung mit Matlab / Simulink und MISRA-C
SEG Automotive Germany GmbH - Stuttgart-Weilimdorf

Softwareentwickler (m/w) automatische Codegenerierung
Umsetzung, Neuprogrammierung und Weiterentwicklung in Simulink, TargetLink und C
EFS - Ingolstadt, Wolfsburg

Informatiker (m/w) für den Bereich Toolkette Embedded Software
Weiterentwicklung einer MATLAB- / Simulink-Toolkette
cbb-Software GmbH - Stuttgart

Softwareentwickler (m/w) für Exoskelette - Perspektive Teamleitung
Programmierung von Mikrocontrollern zur Steuerung, Erarbeiten einer geeigneten Regelungsstruktur
über unternehmensberatung monika gräter - Augsburg

weitere Angebote

Partner:


Vermarktungspartner


Forum
      Option
[Erweitert]
  • Diese Seite per Mail weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Simulink.Variant Parameter

 

Ina24
Forum-Newbie

Forum-Newbie


Beiträge: 1
Anmeldedatum: 14.07.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 28.07.2017, 09:29     Titel: Simulink.Variant Parameter
  Antworten mit Zitat      
Hallo zusammen,

ich habe ein Variant Subsystem in mein Modell implementiert. Wenn ich das Modell neu lade, werden die entsprechenden Variant-Parameter (Preload fct) angelegt. Dann kann ich die Simulation starten und alles verläuft wie erwartet. Mein Problem ist jetzt, das es sein kann, dass wenn das Modell schon geöffnet ist, über eine MATLAB Funktion den Variant- Parametern andere Werte zugewiesen werden (ohne das die eigentliche Simulation gestartet hat). Starte ich die Simulation in diesem Fall bekomme ich eine Fehlermeldung dass die Variant-Parameter geändert wurden und das nicht erlaubt ist. Erst nach nochmaligem Starten läuft die Simulation dann durch. Kann ich diese Fehlermeldung irgendwie umgehen und dafür sorgen, dass das Modell direkt ohne Fehler sich updated und dann simuliert.

Vielen Dank schonmal für Eure Hilfe!

Liebe Grüße,
Ina
Private Nachricht senden Benutzer-Profile anzeigen


Neues Thema eröffnen Neue Antwort erstellen



Einstellungen und Berechtigungen
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum posten
Du kannst Dateien in diesem Forum herunterladen
.


goMatlab ist ein Teil des goForen-Labels
goForen.de goMATLAB.de goLaTeX.de goPCB.de


 Impressum  | Nutzungsbedingungen  | Datenschutz  | Werbung/Mediadaten | Studentenversion | FAQ | goMatlab RSS Button RSS


Copyright © 2007 - 2018 goMatlab.de | Dies ist keine offizielle Website der Firma The Mathworks
Partner: LabVIEWforum.de

MATLAB, Simulink, Stateflow, Handle Graphics, Real-Time Workshop, SimBiology, SimHydraulics, SimEvents, and xPC TargetBox are registered trademarks and The MathWorks, the L-shaped membrane logo, and Embedded MATLAB are trademarks of The MathWorks, Inc.