Esp8266 Matlab UDP Passthrough - Mein MATLAB Forum - goMatlab.de

Mein MATLAB Forum - goMatlab.de

Mein MATLAB Forum

 
Gast > Registrieren       Autologin?   

Bücher:

Fachkräfte:
Softwareentwickler (m/w) automatische Codegenerierung
Umsetzung, Neuprogrammierung und Weiterentwicklung in Simulink, TargetLink und C
EFS - Ingolstadt, Wolfsburg

Informatiker (m/w) für den Bereich Toolkette Embedded Software
Weiterentwicklung einer MATLAB-/Simulink-Toolkette, Automatisierung der Code-Generierung mit TargetLink und Embedded Coder
cbb-Software GmbH - Stuttgart

Systemingenieur (m/w) Mission Planning
Systemengineering der Missionsplanung des Waffensystems
TAURUS Systems GmbH - Schrobenhausen

Berechnungsingenieur Längsdynamik (ICE, HEV, BEV) (m/w)
Simulation von Fahrleistung und Verbrauch für konventionelle Fahrzeuge
MBtech Group GmbH & Co. KGaA - Sindelfingen, Fellbach

Software Testingenieur (m/w)
Planung, Design und Review von Testaktivitäten und -szenarien
HOPPECKE Batterien GmbH & Co. KG - Brilon-Hoppecke

weitere Angebote

Partner:


Vermarktungspartner


Forum
      Option
[Erweitert]
  Diese Seite per Mail weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Esp8266 Matlab UDP Passthrough

 

Stonewall
Forum-Newbie

Forum-Newbie


Beiträge: 7
Anmeldedatum: 10.07.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.07.2017, 12:32     Titel: Esp8266 Matlab UDP Passthrough
  Antworten mit Zitat      
Hallo liebe Leute, Cool

ich hab ein Problem mit dem ESP8266 Passthrough Mode und suche jmd. der damit schon Erfahrung hat.

Vorweg: Der Passthrough Mode via TCP-Verbindung funktioniert einwandfrei, die UDP verbindung funktioniert nur in eine Richtung! Nämlich von Matlab zum ESP, der die Daten dann einfach weiterleitet. Eine UDP Verbindung von Matlab zu Matlab ist auch ohne weiteres möglich. Ist es also vielleicht ein Bug am ESP8266?

Woran könnte das liegen?

Ich öffne mit Matlab eine Verbindung via

u = udp('x.x.x.x')
u.RemotePort=8889
u.LocalPort=8889;
u.InputBufferSize=1024;
u.Timeout=1;
u.Terminator='';
u.DatagramTerminateMode='on';
u.BytesAvailableFcnMode='terminator';
fopen(u)

fprintf(u,'Request Time'); // einwandfrei
fwrite(u,'Request Time'); // einwandfrei
A=fread(u,1,'uint8'); // nichts


In Simulink übrigens genau das gleiche. Senden funktioniert. Empfangen nicht. Firewall und Antivirenprogramm aus am PC bringt leider auch nichts. Aber wie gesagt. TCP funktioniert. Sad

Bin echt super ratlos! Vielen Dank für eure Hilfe!

Stonewall
Private Nachricht senden Benutzer-Profile anzeigen


Neues Thema eröffnen Neue Antwort erstellen



Einstellungen und Berechtigungen
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum posten
Du kannst Dateien in diesem Forum herunterladen
.



goMatlab ist ein Teil des goForen-Labels
goForen.de goMATLAB.de goLaTeX.de goPCB.de


 Impressum  | Nutzungsbedingungen  | Datenschutz  | Werbung/Mediadaten | Studentenversion | FAQ | goMatlab RSS Button RSS


Copyright © 2007 - 2018 goMatlab.de | Dies ist keine offizielle Website der Firma The Mathworks
Partner: LabVIEWforum.de

MATLAB, Simulink, Stateflow, Handle Graphics, Real-Time Workshop, SimBiology, SimHydraulics, SimEvents, and xPC TargetBox are registered trademarks and The MathWorks, the L-shaped membrane logo, and Embedded MATLAB are trademarks of The MathWorks, Inc.