Hyperlink im Command-Window ausgeben - Mein MATLAB Forum - goMatlab.de

Mein MATLAB Forum - goMatlab.de

Mein MATLAB Forum

 
Gast > Registrieren       Autologin?   

Bücher:

Studierende:
Praktikum - Optische Verbrennungsdiagnostik von Zündsystemen mit MATLAB
Branche: mehrere
IAV GmbH - Ingenieurgesellschaft Auto und Verkehr - Berlin

Praktikant (w/m) Toolentwicklung Matlab
Branche: Beratung, Expertise, Fahrzeugtechnik, Fahrzeugteile, Technische Dienstleistungen
MBtech Group GmbH & Co. KGaA - Fellbach

Abschlussarbeit / Praktikum: Entwicklung Matlab (m/w)
Branche: Informationstechnologie, Elektrotechnik, Elektronik
GIGATRONIK Technologies GmbH - Ulm

Praktikum im Bereich R&D - Software
Branche: Elektrotechnik, Elektronik
über Campusjäger GmbH - Böblingen

Praktikum - App-Entwicklung für Raspberry Pi Prototyping System
Branche: Fahrzeugtechnik, Fahrzeugteile, Elektrotechnik, Elektronik
IAV GmbH - Berlin

weitere Angebote

Partner:


Vermarktungspartner


Forum
      Option
[Erweitert]
  Diese Seite per Mail weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Hyperlink im Command-Window ausgeben

 

pewe1835
Forum-Anfänger

Forum-Anfänger


Beiträge: 11
Anmeldedatum: 11.12.08
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 01.02.2018, 18:17     Titel: Hyperlink im Command-Window ausgeben
  Antworten mit Zitat      
Hallo liebe Matlab-Experten,

ch habe folgendes Problem, ich gebe im Command-Window Hyperlinks zur aktuellen bearbeiteten Messdatei aus. Die Ausgabe der Links funktioniert soweit auch sehr gut. Ich habe nur das Problem, dass jeder neue Hyperlink den Zielpfad des alten Hyperlinks überschreibt. Hier hoffe ich jetzt auf einen Lösungsvorschlag von euch. Konkret sieht mein Code folgendermaßen aus:

Code:

for cnt_inx = 1:5
Messungspfad = (['C:\temp\2018\Messung_', num2str(cnt_inx)]);
disp(['<a href="matlab:dos([Messungspfad])">', char(Messungspfad),'</a>'])
end
 


Das Problem ist nun aber, dass Messungspfad zwar korrekt im Command-Window ausgegeben wird, wenn ich allerdings den Link anklicke lande ich immer bei der letzten Messung (in dem Fall bei Messung 5, weil nach dem letzten Schleifendurchlauf cnt_inx = 5 ist). Hat einer von euch eventuell eine Idee wie ich das Problem lösen kann. Ich hoffe ich habe mein Problem ausreichend beschrieben.

VG pewe
Private Nachricht senden Benutzer-Profile anzeigen


Neues Thema eröffnen Neue Antwort erstellen



Einstellungen und Berechtigungen
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum posten
Du kannst Dateien in diesem Forum herunterladen
.



goMatlab ist ein Teil des goForen-Labels
goForen.de goMATLAB.de goLaTeX.de goPCB.de


 Impressum  | Nutzungsbedingungen  | Datenschutz  | Werbung/Mediadaten | Studentenversion | FAQ | goMatlab RSS Button RSS


Copyright © 2007 - 2018 goMatlab.de | Dies ist keine offizielle Website der Firma The Mathworks
Partner: LabVIEWforum.de

MATLAB, Simulink, Stateflow, Handle Graphics, Real-Time Workshop, SimBiology, SimHydraulics, SimEvents, and xPC TargetBox are registered trademarks and The MathWorks, the L-shaped membrane logo, and Embedded MATLAB are trademarks of The MathWorks, Inc.