Probleme mit Zeitachse (System Identification Toolbox) - Mein MATLAB Forum - goMatlab.de

Mein MATLAB Forum - goMatlab.de

Mein MATLAB Forum

 
Gast > Registrieren       Autologin?   

Bücher:

Fachkräfte:
Softwareentwickler (m/w) automatische Codegenerierung
Umsetzung, Neuprogrammierung und Weiterentwicklung in Simulink, TargetLink und C
EFS - Ingolstadt, Wolfsburg

Informatiker (m/w) für den Bereich Toolkette Embedded Software
Weiterentwicklung einer MATLAB-/Simulink-Toolkette, Automatisierung der Code-Generierung mit TargetLink und Embedded Coder
cbb-Software GmbH - Stuttgart

Entwickler Fahrerassistenzsysteme / Fahrzeugnahe Funktionsentwicklung (m/w)
Entwicklung von Funktionen für assistiertes und pilotiertes Fahren
Knorr-Bremse Systeme für Nutzfahrzeuge GmbH - Schwieberdingen bei Stuttgart

Entwicklungsingenieur (w/m) CO2- Lasersysteme
Planung, Durchführung und Auswertung von Tests an CO₂-Hochleistungsverstärkern
TRUMPF Lasersystems for Semiconductor Manufacturing GmbH - Ditzingen

Ingenieur (m/w) Hochspannungstechnik
Entwicklung und Optimierung von Systemen und Komponenten der Hochleistungsimpulstechnik
ISL Deutsch Französisches Forschungsinstitut - Weil am Rhein

weitere Angebote

Partner:


Vermarktungspartner


Forum
      Option
[Erweitert]
  Diese Seite per Mail weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Probleme mit Zeitachse (System Identification Toolbox)

 

Matze89
Forum-Newbie

Forum-Newbie


Beiträge: 2
Anmeldedatum: 23.01.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 23.01.2017, 13:02     Titel: Probleme mit Zeitachse (System Identification Toolbox)
  Antworten mit Zitat      
Hallo zusammen,

für eine Abschlussarbeit möchte ich eine Übertragungsfunktion mit der Systems-Identification-Toolbox herausfinden. Die Messwerte von Ein- und Ausgang (Sprungfunktion und Antwort) habe ich als CSV-Datei importiert, die Abtastrate war 0.01 s. Beim Import habe ich somit "Sample-rate = 0.01" ausgewählt.

Matlab spuckt mir dann auch entsprechende Übertragungsfunktionen aus, die ich in Excel als Differenzengleichung umsetzen möchte. (Später soll ein dynamisches System auf dem Rechner als Rekursionsformel umgesetzt werden)

Mein Problem liegt nun darin, dass beim Plot meiner Gleichungen in Excel die Zeitachse nur passt, wenn ich eine tf-Funktion mit 1 "pole" und 2 "zeros" wähle. Sobald ich von der Ordnung höher gehe, wird meine Sprungantwort in Excel in der x-Achse (Zeit) gestreckt oder gestaucht. Das ganze habe ich im Anhang mal dargestellt. Langsam bin ich am Verzweifeln, weil ich nicht weiss was ich falsch mache... Hat irgendjemand eine Idee, an was das liegen könnte? 

Vergleich_tf-funktion_Matlab,Excel.png
 Beschreibung:

Download
 Dateiname:  Vergleich_tf-funktion_Matlab,Excel.png
 Dateigröße:  122.51 KB
 Heruntergeladen:  135 mal
Private Nachricht senden Benutzer-Profile anzeigen


Neues Thema eröffnen Neue Antwort erstellen



Einstellungen und Berechtigungen
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum posten
Du kannst Dateien in diesem Forum herunterladen
.



goMatlab ist ein Teil des goForen-Labels
goForen.de goMATLAB.de goLaTeX.de goPCB.de


 Impressum  | Nutzungsbedingungen  | Datenschutz  | Werbung/Mediadaten | Studentenversion | FAQ | goMatlab RSS Button RSS


Copyright © 2007 - 2018 goMatlab.de | Dies ist keine offizielle Website der Firma The Mathworks
Partner: LabVIEWforum.de

MATLAB, Simulink, Stateflow, Handle Graphics, Real-Time Workshop, SimBiology, SimHydraulics, SimEvents, and xPC TargetBox are registered trademarks and The MathWorks, the L-shaped membrane logo, and Embedded MATLAB are trademarks of The MathWorks, Inc.